Errors in installing RforProteomics package
0
0
Entering edit mode
Phoebe • 0
@b9a43c13
Last seen 9 months ago

I seemed to have a problem in installing the package, tried multiple times using the installing method suggested but still had this comment stated "installation of package ‘RforProteomics’ had non-zero exit status"

R version 4.0.1 on mac. Please troubleshoot this, thanks. Much appreciated

# sessionInfo here

> sessionInfo()
R version 4.0.1 (2020-06-06)
Platform: x86_64-apple-darwin17.0 (64-bit)
Running under: macOS Sierra 10.12.6

Matrix products: default
BLAS:   /System/Library/Frameworks/Accelerate.framework/Versions/A/Frameworks/vecLib.framework/Versions/A/libBLAS.dylib
LAPACK: /Library/Frameworks/R.framework/Versions/4.0/Resources/lib/libRlapack.dylib

locale:
[1] en_AU.UTF-8/en_AU.UTF-8/en_AU.UTF-8/C/en_AU.UTF-8/en_AU.UTF-8

attached base packages:
[1] stats     graphics  grDevices utils     datasets  methods   base     

other attached packages:
[1] readxl_1.3.1  ggplot2_3.3.2

loaded via a namespace (and not attached):
 [1] Rcpp_1.0.5          rstudioapi_0.13     magrittr_2.0.1      tidyselect_1.1.0    munsell_0.5.0       colorspace_2.0-0   
 [7] R6_2.5.0            rlang_0.4.8         fansi_0.4.1         dplyr_1.0.2         tools_4.0.1         grid_4.0.1         
[13] broom_0.7.2         gtable_0.3.0        xfun_0.19           tinytex_0.27        cli_2.2.0           withr_2.3.0        
[19] ellipsis_0.3.1      assertthat_0.2.1    tibble_3.0.4        lifecycle_0.2.0     crayon_1.3.4        tidyr_1.1.2        
[25] BiocManager_1.30.10 purrr_0.3.4         vctrs_0.3.5         glue_1.4.2          compiler_4.0.1      pillar_1.4.7       
[31] cellranger_1.1.0    backports_1.2.0     generics_0.1.0      scales_1.1.1        pkgconfig_2.0.3
# installation starts here
> if (!requireNamespace("BiocManager", quietly=TRUE))
install.packages("BiocManager")
> BiocManager::install("RforProteomics")
Bioconductor version 3.12 (BiocManager 1.30.10), R 4.0.1 (2020-06-06)
Installing package(s) 'RforProteomics'
installing the source package ‘RforProteomics’

trying URL 'https://bioconductor.org/packages/3.12/data/experiment/src/contrib/RforProteomics_1.27.1.tar.gz'
Content type 'application/x-gzip' length 8219725 bytes (7.8 MB)
==================================================
downloaded 7.8 MB

dyld: lazy symbol binding failed: Symbol not found: _utimensat
  Referenced from: /Library/Frameworks/R.framework/Versions/4.0/Resources/lib/libR.dylib (which was built for Mac OS X 10.13)
  Expected in: /usr/lib/libSystem.B.dylib

dyld: Symbol not found: _utimensat
  Referenced from: /Library/Frameworks/R.framework/Versions/4.0/Resources/lib/libR.dylib (which was built for Mac OS X 10.13)
  Expected in: /usr/lib/libSystem.B.dylib

/Library/Frameworks/R.framework/Resources/bin/INSTALL: line 34: 10289 Done                    echo 'tools:::.install_packages()'
     10290 Abort trap: 6           | R_DEFAULT_PACKAGES= LC_COLLATE=C "${R_HOME}/bin/R" $myArgs --no-echo --args ${args}

The downloaded source packages are in
    ‘/private/var/folders/r1/t43yb0ps6c10rjpqstz792l40000gn/T/RtmpT7LvVo/downloaded_packages’
Old packages: 'rmarkdown'
Update all/some/none? [a/s/n]: 
a

  There is a binary version available but the source version is later:
          binary source needs_compilation
rmarkdown    2.3    2.5             FALSE

installing the source package ‘rmarkdown’

trying URL 'https://cran.rstudio.com/src/contrib/rmarkdown_2.5.tar.gz'
Content type 'application/x-gzip' length 3203415 bytes (3.1 MB)
==================================================
downloaded 3.1 MB

dyld: lazy symbol binding failed: Symbol not found: _utimensat
  Referenced from: /Library/Frameworks/R.framework/Versions/4.0/Resources/lib/libR.dylib (which was built for Mac OS X 10.13)
  Expected in: /usr/lib/libSystem.B.dylib

dyld: Symbol not found: _utimensat
  Referenced from: /Library/Frameworks/R.framework/Versions/4.0/Resources/lib/libR.dylib (which was built for Mac OS X 10.13)
  Expected in: /usr/lib/libSystem.B.dylib

/Library/Frameworks/R.framework/Resources/bin/INSTALL: line 34: 10306 Done                    echo 'tools:::.install_packages()'
     10307 Abort trap: 6           | R_DEFAULT_PACKAGES= LC_COLLATE=C "${R_HOME}/bin/R" $myArgs --no-echo --args ${args}

The downloaded source packages are in
    ‘/private/var/folders/r1/t43yb0ps6c10rjpqstz792l40000gn/T/RtmpT7LvVo/downloaded_packages’
Warning messages:
1: In install.packages(...) :
  installation of package ‘RforProteomics’ had non-zero exit status
2: In install.packages(update[instlib == l, "Package"], l, repos = repos,  :
  installation of package ‘rmarkdown’ had non-zero exit status`
error RforProteomics Install • 232 views
ADD COMMENT
1
Entering edit mode

I'll caveat this with the fact that I'm not a Mac user and perhaps there's a simple solution, but it looks to me like you're running Mac OS X Sierra 10.12.6 but R-4.0 is only available for (or at least supported on) for Mac OS X High Sierra 10.13.

You can download R-3.6 for 'legacy OS X systems' from https://cran.r-project.org/bin/macosx/ but maybe it's time to upgrade your version of OS X?

ADD REPLY

Login before adding your answer.

Traffic: 234 users visited in the last hour
Help About
FAQ
Access RSS
API
Stats

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.

Powered by the version 2.3.6