Is S4Vectors not able to install in R-3.5.1?
0
0
Entering edit mode
zhang303 • 0
@zhang303-18828
Last seen 2.8 years ago

Hi all,

I was trying to install "S4Vectors" using "BiocInstaller" on R-3.5.1

But it gives error as "eval_utils.c:33: error: 'for' loop initial declarations are only allowed in C99 mode".

And It seems not to be a general problem.

Does anyone else encounter and solve the problem?

Thanks,

Yifang

 

It shows the following:

> if (!requireNamespace("BiocManager", quietly = TRUE))

+     install.packages("BiocManager")

> BiocManager::install("S4Vectors", version = "3.8")

Bioconductor version 3.8 (BiocManager 1.30.4), R 3.5.1 (2018-07-02)

Installing package(s) 'S4Vectors'

trying URL 'https://bioconductor.org/packages/3.8/bioc/src/contrib/S4Vectors_0.20.1.tar.gz'

Content type 'application/x-gzip' length 633420 bytes (618 KB)

==================================================

downloaded 618 KB

 

* installing *source* package 'S4Vectors' ...

** libs

gcc -I"/usr/local/apps/bioapps/R/R-3.5.1/lib64/R/include" -DNDEBUG   -I/usr/local/curl/7.28.0/include -I/usr/local/pcre/8.40/include -I/usr/local/xz/5.2.3/include -I/usr/local/bzip2/1.0.6/include -I/usr/local/zlib/1.2.8/include   -fpic  -g -O2  -c AEbufs.c -o AEbufs.o

....

....

gcc -I"/usr/local/apps/bioapps/R/R-3.5.1/lib64/R/include" -DNDEBUG   -I/usr/local/curl/7.28.0/include -I/usr/local/pcre/8.40/include -I/usr/local/xz/5.2.3/include -I/usr/local/bzip2/1.0.6/include -I/usr/local/zlib/1.2.8/include   -fpic  -g -O2  -c eval_utils.c -o eval_utils.o

eval_utils.c: In function 'top_prenv_dots':

eval_utils.c:33: error: 'for' loop initial declarations are only allowed in C99 mode

eval_utils.c:33: note: use option -std=c99 or -std=gnu99 to compile your code

make: *** [eval_utils.o] Error 1

ERROR: compilation failed for package 'S4Vectors'

 

S4Vectors R-3.5.1 • 809 views
ADD COMMENT
0
Entering edit mode

I could install it without error. Maybe it is related to 32/64 bytes difference or to an invalid version of Bioconductor (Try BiocManager::valid())

ADD REPLY

Login before adding your answer.

Traffic: 214 users visited in the last hour
Help About
FAQ
Access RSS
API
Stats

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.

Powered by the version 2.3.6