Question: problem with update limma - green channel missing
0
gravatar for wd
4.6 years ago by
wd30
Germany
wd30 wrote:

Hi 

I'm trying to analyze 8x 60 k Agilent data using the latest version of Bioconductor and Limma in Rstudio (MacOSX, Yosemite). I read in the microarray data using the following commands:

targets<-readTargets("target_RR.txt")
RG<-read.maimages(targets$FileName, source="agilent")
plotDensities(RG)

but when I look at the plot the GREEN channel is NOT plotted at all! 

One month ago, I ran exactly the same commands/script but with an older version of Bioconductor/Limma and BOTH RED and GREEN channels were plotted back then, so it seems that the problem is related to the most recent update of limma...

It seem that my question is also related to this one (http://www.biostars.org/p/129469/) but so far no solution has yet been found.

Thank you for helping!

Regards

Wannes

PS1: I also ran the command on Rstudio in Windows but got exactly the same problem.

PS2: the "target_RR.txt" file looks like this:

ID    Name    FileName    Cy5    Cy3    Target

1    f1    US22502421_253385010016_S01_GE2_107_Sep09_2_2.txt    R    NR    r
2    f2    US22502421_253385010016_S01_GE2_107_Sep09_2_4.txt    R    NR    r
3    f3    US22502421_253385010016_S01_GE2_107_Sep09_1_3.txt    R    NR    r
4    f4    US22502421_253385010016_S01_GE2_107_Sep09_1_1.txt    R    NR    r

 

ADD COMMENTlink modified 4.6 years ago • written 4.6 years ago by wd30

Dear Gordon

Thank you for fixing the issue!

However, could it be that limma 3.22.6 is not yet available at http://www.bioconductor.org/packages/release/bioc/html/limma.html or is it available at another website?

Regards

Wannes

ADD REPLYlink written 4.6 years ago by wd30

It takes a few days for Bioconductor to build a new public copy of a package when it is updated.

ADD REPLYlink written 4.6 years ago by Gordon Smyth38k
Answer: problem with update limma - green channel missing
0
gravatar for Gordon Smyth
4.6 years ago by
Gordon Smyth38k
Walter and Eliza Hall Institute of Medical Research, Melbourne, Australia
Gordon Smyth38k wrote:

Sorry, I introduced this bug when I tried to make the methods dispatching of plotDensities() more "elegant".

I have committed a fix in limma 3.22.6.

ADD COMMENTlink written 4.6 years ago by Gordon Smyth38k
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 16.09
Traffic: 202 users visited in the last hour