Question: ChIPseeker: covplot function: error with some ENCODE data sets
0
gravatar for sarabusquets88
4.5 years ago by
Netherlands
sarabusquets880 wrote:

I am performing an exploratory analysis of the ENCODE Txn Factor ChiPseq data. For some reason that I cannot understand, the covplot function only works for certain input files. It works perfectly for certain input files but when I change just the input file and maintain the script the same I get the following error. All the files I want to analyze come from the ENCODE databse and are .narrowpeaks or .broadpeaks format. Then I transform them to a GRanges file to analyze them.

> covplot <- covplot(my_granges,weightCol ="score") #coverage plot

Error in data.frame(chr = names(cov[i]), start = start(x), end = end(x),  : 
  arguments imply differing number of rows: 1, 118, 119

For example, when I use the ENCODE ChiPseq data for BCL11A in hESC.narrowpeaks or BCL11A in hESC Replicate 1.broadpeaks it works, but when I use BCL11A in hESC Replicate2.broadpeaks, it does not work.

 

chipseq chipseeker covplot encode • 1.1k views
ADD COMMENTlink modified 4.5 years ago • written 4.5 years ago by sarabusquets880
Answer: ChIPseeker: covplot function: error with some ENCODE data sets
1
gravatar for Guangchuang Yu
4.5 years ago by
Guangchuang Yu1.1k
China/Guangzhou/Southern Medical University
Guangchuang Yu1.1k wrote:

please post the link to download this encode dataset, I will have a look at it.

Bests,

Guangchuang
 

ADD COMMENTlink written 4.5 years ago by Guangchuang Yu1.1k
Answer: ChIPseeker: covplot function: error with some ENCODE data sets
1
gravatar for wenhuo hu
4.5 years ago by
wenhuo hu200
United States
wenhuo hu200 wrote:

It works right now if this: install_github("GuangchuangYu/ChIPseeker") Thanks man.

ADD COMMENTlink modified 4.5 years ago • written 4.5 years ago by wenhuo hu200

please cite this paper: http://www.ncbi.nlm.nih.gov/pubmed/25765347

 

Thanks.

ADD REPLYlink written 4.5 years ago by Guangchuang Yu1.1k
Answer: ChIPseeker: covplot function: error with some ENCODE data sets
0
gravatar for sarabusquets88
4.5 years ago by
Netherlands
sarabusquets880 wrote:

Dear Guangchuang,

Thanks for your reply!

 - This is replicate 1 of BCL11A ChIPseq in hESC from ENCODE (the one that works): 

https://www.genome.ucsc.edu/cgi-bin/hgTrackUi?hgsid=424063059_EqT7VUHDesA7tH02ocEyI12cm5kE&g=wgEncodeHaibTfbsH1hescBcl11aPcr1xPkRep1

- This is replicate 2 of BCL11A ChIPseq in hESC from ENCODE (the one that does not work):

https://www.genome.ucsc.edu/cgi-bin/hgTrackUi?hgsid=424063059_EqT7VUHDesA7tH02ocEyI12cm5kE&g=wgEncodeHaibTfbsH1hescBcl11aV0416102PkRep2

You have to click on "metadata", and then the link to download the file will appear.

Thank you very much for looking into this!

 

Best,

 

Sara

 

ADD COMMENTlink written 4.5 years ago by sarabusquets880
Answer: ChIPseeker: covplot function: error with some ENCODE data sets
0
gravatar for Guangchuang Yu
4.5 years ago by
Guangchuang Yu1.1k
China/Guangzhou/Southern Medical University
Guangchuang Yu1.1k wrote:

Thanks for your report. It has been fixed in version >=1.4.1

Please wait 2-3 days for Bioconductor to update tarball.
 

ADD COMMENTlink written 4.5 years ago by Guangchuang Yu1.1k
Answer: ChIPseeker: covplot function: error with some ENCODE data sets
0
gravatar for sarabusquets88
4.5 years ago by
Netherlands
sarabusquets880 wrote:

Thank you very much!

It works perfectly!

 

ADD COMMENTlink written 4.5 years ago by sarabusquets880
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 16.09
Traffic: 372 users visited in the last hour