Search
Question: Issues parsing workspace in openCyto
0
gravatar for JK
2.2 years ago by
JK10
United States
JK10 wrote:

Hi,

I am trying to parse a workspace in openCyto and getting the error message below:

 


> ws
FlowJo Workspace Version  20.0
File location:  .
File name:  20150714_b.wsp
Workspace is open.

Groups in Workspace
         Name Num.Samples
1 All Samples           1
> gs=parseWorkspace(ws)
Choose which group of samples to import:

1: All Samples

Selection: 1
Parsing 1 samples
calling c++ parser...
windows version of flowJo workspace recognized.
version X
c++ parsing done!
Error in list.files(pattern = paste("^", file, "", sep = ""), path = path,  :
  invalid 'pattern' regular expression

> sessionInfo()
R version 3.1.2 (2014-10-31)
Platform: x86_64-w64-mingw32/x64 (64-bit)

locale:
[1] LC_COLLATE=English_United States.1252  LC_CTYPE=English_United States.1252    LC_MONETARY=English_United States.1252
[4] LC_NUMERIC=C                           LC_TIME=English_United States.1252    

attached base packages:
[1] grid      stats     graphics  grDevices utils     datasets  methods   base     

other attached packages:
[1] openCyto_1.4.0            flowWorkspace_3.12.06     gridExtra_0.9.1           ncdfFlow_2.12.0           BH_1.54.0-5             
[6] RcppArmadillo_0.4.550.1.0 flowViz_1.30.1            lattice_0.20-29           flowCore_1.32.2           BiocInstaller_1.16.5     

loaded via a namespace (and not attached):
[1] Biobase_2.26.0        BiocGenerics_0.12.1   chron_2.3-45          clue_0.3-48           cluster_1.15.3        coda_0.16-1         
[7] colorspace_1.2-4      corpcor_1.6.7         data.table_1.9.4      DEoptimR_1.0-2        digest_0.6.4          fda_2.4.3           
[13] flowClust_3.4.11      flowStats_3.24.8      GGally_0.4.8          ggplot2_1.0.0         graph_1.44.1          gtable_0.1.2        
[19] gtools_3.4.1          hexbin_1.27.0         IDPmisc_1.1.17        KernSmooth_2.23-13    ks_1.9.3              latticeExtra_0.6-26 
[25] MASS_7.3-35           Matrix_1.1-4          MCMCpack_1.3-3        misc3d_0.8-4          munsell_0.4.2         mvoutlier_2.0.5     
[31] mvtnorm_1.0-1         parallel_3.1.2        pcaPP_1.9-60          pls_2.4-3             plyr_1.8.1            proto_0.3-10        
[37] R.methodsS3_1.6.1     R.oo_1.18.0           R.utils_1.34.0        RBGL_1.42.0           RColorBrewer_1.0-5    Rcpp_0.11.3         
[43] reshape_0.8.5         reshape2_1.4          rgl_0.95.1158         Rgraphviz_2.10.0      robCompositions_1.9.0 robustbase_0.92-2   
[49] rrcov_1.3-4           scales_0.2.4          sgeostat_1.0-25       stats4_3.1.2          stringr_0.6.2         tools_3.1.2         
[55] XML_3.98-1.1          zlibbioc_1.12.0     

 

I would appreciate suggestions on what may be going wrong here.

 

Thanks,

 

Joe

ADD COMMENTlink modified 2.2 years ago • written 2.2 years ago by JK10

You may want to upgrade your bioconductor to the latest release BioC 3.1. (i.e. flowWorkspace 3.14.6)

ADD REPLYlink written 2.2 years ago by Jiang, Mike1.0k

I tried already; it did not solve the issue.

I have been trying a couple of things. The issue may be related to the version of FACSDiva used on the machine for acquiring my data. The data I have been trying to parse is from a BD Influx.

ADD REPLYlink written 2.2 years ago by JK10
0
gravatar for JK
2.2 years ago by
JK10
United States
JK10 wrote:

Issue is resolved. wsp format from FlowJo did not work. Had to use xml export of workspace. 

ADD COMMENTlink written 2.2 years ago by JK10

Interesting, we've been parsing wsp files without problems.(since they are still in xml format). And from the message, it was parsing wsp fine, the error seems to have to do with the sample Names.

ADD REPLYlink modified 2.2 years ago • written 2.2 years ago by Jiang, Mike1.0k
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 2.2.0
Traffic: 182 users visited in the last hour