Question: Help with AMI hosted on bioconductor page, ami-a3d126c8
0
gravatar for nitesh.turaga
4.0 years ago by
nitesh.turaga140
United States
nitesh.turaga140 wrote:

Hi,

I'm trying to use BiocParallel on the AWS EC2 service using the AMI provided on this page http://www.bioconductor.org/help/bioconductor-cloud-ami/#custom (AMI ID: ami-a3d126c8)

When I try to reproduce the vignette, I get the error that not all parallel infrastructures are recognized in this build of the image. Can someone help me run through the vignette as given without producing errors? Is it possible on the AMI's given by bioconductor. 

> library(BiocParallel)
'BiocParallel' did not register default BiocParallelParams:
  invalid class “SnowParam” object: 'workers' must be integer(1) and >= 0

> sessionInfo()
R version 3.2.1 (2015-06-18)
Platform: x86_64-unknown-linux-gnu (64-bit)
Running under: Ubuntu 14.04.2 LTS

locale:
 [1] LC_CTYPE=en_US.UTF-8       LC_NUMERIC=C
 [3] LC_TIME=en_US.UTF-8        LC_COLLATE=en_US.UTF-8
 [5] LC_MONETARY=en_US.UTF-8    LC_MESSAGES=en_US.UTF-8
 [7] LC_PAPER=en_US.UTF-8       LC_NAME=C
 [9] LC_ADDRESS=C               LC_TELEPHONE=C
[11] LC_MEASUREMENT=en_US.UTF-8 LC_IDENTIFICATION=C

attached base packages:
[1] stats     graphics  grDevices utils     datasets  methods   base

other attached packages:
[1] BiocParallel_1.3.31  BiocInstaller_1.19.6

loaded via a namespace (and not attached):
[1] parallel_3.2.1       futile.logger_1.4.1  lambda.r_1.1.7
[4] futile.options_1.0.0

 

 

Thanks.

 

biocparallel amazon • 749 views
ADD COMMENTlink modified 4.0 years ago • written 4.0 years ago by nitesh.turaga140

It looks like you posted a follow up and then retracted it. Just to clarify -

The AMI comes pre-loaded with a snapshot of the current packages at the time and is not updated regularly. Because the devel branch is under constant development it would not be surprising that one of these packages has a bug. (Things are much more stable in the release branch.) I asked you to update so we would be working with the same versions when troubleshooting. It's not the case that 1.3.51 is the only version that works with the AMI, it is just the most recent devel version.

I'm sorry if it took a lot of time to update all packages. I should have mentioned that you can update a single package with biocLite("BiocParallel").

Valerie

ADD REPLYlink modified 4.0 years ago • written 4.0 years ago by Valerie Obenchain6.7k
Answer: Help with AMI hosted on bioconductor page, ami-a3d126c8
0
gravatar for Valerie Obenchain
4.0 years ago by
United States
Valerie Obenchain6.7k wrote:

Hi,

Yes, BiocParallel works on the AMI and I can help walk you through the vignette.

First you need to update your version of BiocParallel and other packages. Run

biocLite()

Check to make sure BiocParallel 1.3.51 was installed. Then try the vignette again.

Valerie

ADD COMMENTlink written 4.0 years ago by Valerie Obenchain6.7k
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 16.09
Traffic: 82 users visited in the last hour