Plotting protein-protein interaction enrichment with STRINGdb
0
0
Entering edit mode
@lluis-revilla-sancho
Last seen 2 hours ago
European Union

I have encountered an error I couldn't find on the help page and the vignette:

string_db$plot_ppi_enrichment(string_id$STRING_id,
                      title = paste("Interaction enrichment of", moduleName))
Error in (function (classes, fdef, mtable)  :
  unable to find an inherited method for function ‘nodes’ for signature ‘"igraph"’
Calls: sapply ... ppie.getNumEdgesBetween -> unlist -> neighborhood -> nodes -> <Anonymous>
Execution halted

I could successfully plot other groups of proteins, this one is however one of the biggest I have plotted it has 358 proteins and 2270 interactions according to the following code, which ran correctly:

string_db$plot_network(string_id$STRING_id, # payload_id = payload,
                           add_link = FALSE)

After further exploring the issue I found that:

tryCatch({string_db$plot_ppi_enrichment(string_id$STRING_id,
                      title = paste("Interaction enrichment of", moduleName))},
             error = function(e) {
               message("Couldn't map the enrichment of STRING")
               sessionInfo()
               message(e)
             })

|=================================                                     |  47%Couldn't map the enrichment of STRING

unable to find an inherited method for function ‘nodes’ for signature ‘"igraph"’Analyzing purple module!
'select()' returned 1:1 mapping between keys and columns
Warning:  we couldn't map to STRING 3% of your identifiers
ERROR: We do not support lists with more than 400 genes.
Please reduce the size of your input and rerun the analysis.     
Error in get_png(string_ids, payload_id = payload_id, required_score = required_score)
 

If there is an error why is still the get_png method called? Why can it work with 358 proteins if the limit is 400? Which is this file which is being downloaded as implied with the "|  47%" ? Why I can't create graphs bigger than 400?

My session:

R version 3.2.3 (2015-12-10)
Platform: x86_64-pc-linux-gnu (64-bit)
Running under: Ubuntu 14.04.2 LTS

locale:
 [1] LC_CTYPE=en_US.UTF-8       LC_NUMERIC=C              
 [3] LC_TIME=es_ES.UTF-8        LC_COLLATE=en_US.UTF-8    
 [5] LC_MONETARY=es_ES.UTF-8    LC_MESSAGES=en_US.UTF-8   
 [7] LC_PAPER=es_ES.UTF-8       LC_NAME=C                 
 [9] LC_ADDRESS=C               LC_TELEPHONE=C            
[11] LC_MEASUREMENT=es_ES.UTF-8 LC_IDENTIFICATION=C       

attached base packages:
[1] stats     graphics  grDevices utils     datasets  methods   base     

other attached packages:
 [1] STRINGdb_1.10.1    hash_2.2.6         gplots_3.0.1       RColorBrewer_1.1-2
 [5] plotrix_3.6-2      RCurl_1.95-4.8     bitops_1.0-6       igraph_1.0.1      
 [9] plyr_1.8.4         sqldf_0.4-10       RSQLite_1.0.0      DBI_0.4-1         
[13] gsubfn_0.6-6       proto_0.3-10       png_0.1-8         

loaded via a namespace (and not attached):
[1] Rcpp_0.12.5        gtools_3.5.0       chron_2.3-47       magrittr_1.5      
[5] KernSmooth_2.23-15 gdata_2.17.0       caTools_1.17.1     tcltk_3.2.3       

stringdb error • 772 views
ADD COMMENT
0
Entering edit mode

I can't edit the original question to include information to be reproducible (because then it would be too long)

ADD REPLY

Login before adding your answer.

Traffic: 440 users visited in the last hour
Help About
FAQ
Access RSS
API
Stats

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.

Powered by the version 2.3.6