Error with MSA package - could not find symbol "recursive"
1
0
Entering edit mode
cmdcolin ▴ 10
@cmdcolin-12337
Last seen 4.9 years ago
I was seeing an error about not finding a symbol "recursive" doing an MSA. I think I may have upgraded from R 3.3.2 to 3.3.3 and previously msa had worked
> library(msa)
> library(Biostrings)
> 
> x="ATGC"
> y="ATGA"
> z=msa(c(x,y), type="dna")
use default substitution matrix
Error in .Primitive("c")(<s4 object="" of="" class="" "iranges"="">) : 
  could not find symbol "recursive" in environment of the generic function
> devtools::session_info()
Session info -------------------------------------------------------------------
 setting  value                       
 version  R version 3.3.3 (2017-03-06)
 system   x86_64, darwin16.4.0        
 ui       unknown                     
 language (EN)                        
 collate  en_US.UTF-8                 
 tz       America/Detroit             
 date     2017-03-10                  

Packages -----------------------------------------------------------------------
 package       * version date       source        
 ape             4.1     2017-02-14 CRAN (R 3.3.2)
 BiocGenerics  * 0.20.0  2017-02-09 Bioconductor  
 BiocInstaller * 1.24.0  2017-02-09 Bioconductor  
 Biostrings    * 2.42.1  2017-02-09 Bioconductor  
 devtools        1.12.0  2016-12-05 CRAN (R 3.3.2)
 digest          0.6.12  2017-01-27 CRAN (R 3.3.2)
 htmltools       0.3.5   2016-03-21 CRAN (R 3.3.2)
 htmlwidgets     0.8     2016-11-09 CRAN (R 3.3.2)
 IRanges       * 2.8.1   2017-02-09 Bioconductor  
 lattice         0.20-34 2016-09-06 CRAN (R 3.3.3)
 memoise         1.0.0   2016-01-29 CRAN (R 3.3.2)
 msa           * 1.6.0   2017-03-10 Bioconductor  
 msaR            0.2.0   2017-02-24 CRAN (R 3.3.3)
 nlme            3.1-131 2017-02-06 CRAN (R 3.3.3)
 Rcpp            0.12.9  2017-01-14 CRAN (R 3.3.2)
 S4Vectors     * 0.12.1  2017-02-09 Bioconductor  
 withr           1.0.2   2016-06-20 CRAN (R 3.3.2)
 XVector       * 0.14.0  2017-02-09 Bioconductor  
 zlibbioc        1.20.0  2017-02-09 Bioconductor  
msa • 1.5k views
ADD COMMENT
2
Entering edit mode
@martin-morgan-1513
Last seen 14 days ago
United States

See hereĀ A: Combining RangedData objects is broken (IRanges 2.8.1 with R version 3.3.3 RC) for a similar problem -- reinstall your Bioconductor packages.

ADD COMMENT
0
Entering edit mode

Thanks! I did a full reinstall of all from source and it worked afterwords

ADD REPLY

Login before adding your answer.

Traffic: 280 users visited in the last hour
Help About
FAQ
Access RSS
API
Stats

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.

Powered by the version 2.3.6