Search
Question: Error with MSA package - could not find symbol "recursive"
0
gravatar for cmdcolin
16 months ago by
cmdcolin10
cmdcolin10 wrote:
I was seeing an error about not finding a symbol "recursive" doing an MSA. I think I may have upgraded from R 3.3.2 to 3.3.3 and previously msa had worked
> library(msa)
> library(Biostrings)
> 
> x="ATGC"
> y="ATGA"
> z=msa(c(x,y), type="dna")
use default substitution matrix
Error in .Primitive("c")(<s4 object="" of="" class="" "iranges"="">) : 
  could not find symbol "recursive" in environment of the generic function
> devtools::session_info()
Session info -------------------------------------------------------------------
 setting  value                       
 version  R version 3.3.3 (2017-03-06)
 system   x86_64, darwin16.4.0        
 ui       unknown                     
 language (EN)                        
 collate  en_US.UTF-8                 
 tz       America/Detroit             
 date     2017-03-10                  

Packages -----------------------------------------------------------------------
 package       * version date       source        
 ape             4.1     2017-02-14 CRAN (R 3.3.2)
 BiocGenerics  * 0.20.0  2017-02-09 Bioconductor  
 BiocInstaller * 1.24.0  2017-02-09 Bioconductor  
 Biostrings    * 2.42.1  2017-02-09 Bioconductor  
 devtools        1.12.0  2016-12-05 CRAN (R 3.3.2)
 digest          0.6.12  2017-01-27 CRAN (R 3.3.2)
 htmltools       0.3.5   2016-03-21 CRAN (R 3.3.2)
 htmlwidgets     0.8     2016-11-09 CRAN (R 3.3.2)
 IRanges       * 2.8.1   2017-02-09 Bioconductor  
 lattice         0.20-34 2016-09-06 CRAN (R 3.3.3)
 memoise         1.0.0   2016-01-29 CRAN (R 3.3.2)
 msa           * 1.6.0   2017-03-10 Bioconductor  
 msaR            0.2.0   2017-02-24 CRAN (R 3.3.3)
 nlme            3.1-131 2017-02-06 CRAN (R 3.3.3)
 Rcpp            0.12.9  2017-01-14 CRAN (R 3.3.2)
 S4Vectors     * 0.12.1  2017-02-09 Bioconductor  
 withr           1.0.2   2016-06-20 CRAN (R 3.3.2)
 XVector       * 0.14.0  2017-02-09 Bioconductor  
 zlibbioc        1.20.0  2017-02-09 Bioconductor  
msa
ADD COMMENTlink modified 16 months ago by Martin Morgan ♦♦ 22k • written 16 months ago by cmdcolin10
2
gravatar for Martin Morgan
16 months ago by
Martin Morgan ♦♦ 22k
United States
Martin Morgan ♦♦ 22k wrote:

See here A: Combining RangedData objects is broken (IRanges 2.8.1 with R version 3.3.3 RC) for a similar problem -- reinstall your Bioconductor packages.

ADD COMMENTlink written 16 months ago by Martin Morgan ♦♦ 22k

Thanks! I did a full reinstall of all from source and it worked afterwords

ADD REPLYlink written 16 months ago by cmdcolin10
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 2.2.0
Traffic: 295 users visited in the last hour