Trouble installing splatter
3
0
Entering edit mode
luke.zappia ▴ 50
@lukezappia-11973
Last seen 7 months ago

Question received via email:

Hello! I have been having a really hard time installing splatter.

I get a lot of errors saying splatter is not compatible with various versions of R.

 

Then after upgrading to R 3.4.0, I tried 

 

biocLite("Oshlack/splatter", dependencies = TRUE, build_vignettes = TRUE)

 

But it failed after:

Old packages: 'fields'

Update all/some/none? [a/s/n]: 

a


There is a binary version available but the source version is later:

       binary source needs_compilation

fields   8.10   8.15              TRUE


Do you want to install from sources the package which needs compilation?

y/n: y

installing the source package ‘fields’


trying URL 'https://cran.rstudio.com/src/contrib/fields_8.15.tar.gz'

Content type 'application/x-gzip' length 3264130 bytes (3.1 MB)

==================================================

downloaded 3.1 MB


* installing *source* package ‘fields’ ...

** package ‘fields’ successfully unpacked and MD5 sums checked

** libs

clang -I/Library/Frameworks/R.framework/Resources/include -DNDEBUG   -I/usr/local/include   -fPIC  -Wall -g -O2  -c ExponentialUpperC.c -o ExponentialUpperC.o

clang -I/Library/Frameworks/R.framework/Resources/include -DNDEBUG   -I/usr/local/include   -fPIC  -Wall -g -O2  -c addToDiagC.c -o addToDiagC.o

clang -I/Library/Frameworks/R.framework/Resources/include -DNDEBUG   -I/usr/local/include   -fPIC  -Wall -g -O2  -c compactToMatC.c -o compactToMatC.o

clang -I/Library/Frameworks/R.framework/Resources/include -DNDEBUG   -I/usr/local/include   -fPIC  -Wall -g -O2  -c compactToMatCOLD.c -o compactToMatCOLD.o

gfortran   -fPIC  -g -O2  -c css.f -o css.o

make: gfortran: No such file or directory

make: *** [css.o] Error 1

ERROR: compilation failed for package ‘fields’

* removing ‘/Library/Frameworks/R.framework/Versions/3.4/Resources/library/fields’

* restoring previous ‘/Library/Frameworks/R.framework/Versions/3.4/Resources/library/fields’


The downloaded source packages are in

‘/private/var/folders/7w/0ng7rdx178j_5hhd1hqxqr4h0000gr/T/RtmpTtYBav/downloaded_packages’

Warning message:

In install.packages(update[instlib == l, "Package"], l, repos = repos,  :

  installation of package ‘fields’ had non-zero exit status
installation splatter • 1.2k views
ADD COMMENT
0
Entering edit mode
luke.zappia ▴ 50
@lukezappia-11973
Last seen 7 months ago

Hi

It looks as though your problem is with the fields package rather than Splatter. From a quick look it seems like fields is designed for spatial data. It is not required by Splatter so you should be able to say no to updating fields without any bad effects (unless you are using it for something else).

Splatter is now available in the Bioconductor release so you can run

biocLite("splatter")

rather than

biocLite("Oshlack/splatter", dependencies = TRUE, build_vignettes = TRUE)

Hope that helps

ADD COMMENT
0
Entering edit mode
barb.bryant ▴ 10
@barbbryant-13024
Last seen 4.0 years ago

Thanks!

When I use R 3.3.2 and Bioconductor 3.4, it appears splatter is not available for those versions.

After installing the latest R (3.4.0, and using Bioconductor 3.5 (BiocInstaller 1.26.0), installation completed.

 

Should I be concerned about any of the following warnings that I got after "library(splatter)"?

 


Warning: namespace ‘SummarizedExperiment’ is not available and has been replaced
by .GlobalEnv when processing object ‘’
Warning: namespace ‘SummarizedExperiment’ is not available and has been replaced
by .GlobalEnv when processing object ‘’
Warning: namespace ‘SummarizedExperiment’ is not available and has been replaced
by .GlobalEnv when processing object ‘’
Warning: namespace ‘DelayedArray’ is not available and has been replaced
by .GlobalEnv when processing object ‘’
Warning: namespace ‘GenomicRanges’ is not available and has been replaced
by .GlobalEnv when processing object ‘’
Warning: namespace ‘GenomeInfoDb’ is not available and has been replaced
by .GlobalEnv when processing object ‘’
Warning: namespace ‘XVector’ is not available and has been replaced
by .GlobalEnv when processing object ‘’
Warning: namespace ‘SummarizedExperiment’ is not available and has been replaced
by .GlobalEnv when processing object ‘’
Warning: namespace ‘DelayedArray’ is not available and has been replaced
by .GlobalEnv when processing object ‘’
Warning: namespace ‘GenomicRanges’ is not available and has been replaced
by .GlobalEnv when processing object ‘’
Warning: namespace ‘GenomeInfoDb’ is not available and has been replaced
by .GlobalEnv when processing object ‘’
Warning: namespace ‘XVector’ is not available and has been replaced
by .GlobalEnv when processing object ‘’
Warning: namespace ‘SummarizedExperiment’ is not available and has been replaced
by .GlobalEnv when processing object ‘’

 

ADD COMMENT
0
Entering edit mode
luke.zappia ▴ 50
@lukezappia-11973
Last seen 7 months ago

Yes you will need those versions of R/Bioconductor, I should have mentioned that in my answer. From a quick google I think those warnings are caused by objects in your workspace. I don't think they should effect your ability to use Splatter.

ADD COMMENT

Login before adding your answer.

Traffic: 390 users visited in the last hour
Help About
FAQ
Access RSS
API
Stats

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.

Powered by the version 2.3.6