Search
Question: readCufflinks problem with extdata
3
gravatar for biakemi
4 months ago by
biakemi30
biakemi30 wrote:

Hi,

 

I recently started working with RNA-Seq and I reached the step where I analyze my data using cummeRbund. I thought of doing some tutorials first to get to know the package, but I'm having problems with that.

I followed the instructions in the sample workflow:

 

source("https://bioconductor.org/biocLite.R")
biocLite("cummeRbund")
library(cummeRbund)

cuff <- readCufflinks(dir=system.file("extdata", package="cummeRbund"))

 

But when I run the readCufflinks command, the following errors appear:

Creating database /Library/Frameworks/R.framework/Versions/3.4/Resources/library/cummeRbund/extdata/cuffData.db
Reading Run Info File /Library/Frameworks/R.framework/Versions/3.4/Resources/library/cummeRbund/extdata/run.info
Writing runInfo Table
Reading Read Group Info  /Library/Frameworks/R.framework/Versions/3.4/Resources/library/cummeRbund/extdata/read_groups.info
Writing replicates Table
Reading /Library/Frameworks/R.framework/Versions/3.4/Resources/library/cummeRbund/extdata/genes.fpkm_tracking
Checking samples table...
Populating samples table...
Error: Column name mismatch.
In addition: There were 50 or more warnings (use warnings() to see the first 50)

I thought it was weird, since it is a tutorial data, so the columns should have the correct name? Would this be an issue of installation? Any help is welcomed!

ADD COMMENTlink modified 8 weeks ago by markus.ball10 • written 4 months ago by biakemi30
4
gravatar for Oskar
4 months ago by
Oskar40
Oskar40 wrote:

Many thanks for all those answers. Here I copy and paste how I get this package working in R v. 3.3.3 (Windows users)

source("https://bioconductor.org/biocLite.R")
biocLite()

##### To install old version of packages:
install.packages("devtools")
require(devtools)

install_version("RSQLite", version = "1.1-2", repos = "http://cran.us.r-project.org")

biocLite("cummeRbund")
library(cummeRbund)

Here's my sessionInfo()

attached base packages:
 [1] grid      stats4    parallel  stats     graphics  grDevices utils     datasets  methods   base     

other attached packages:
 [1] cummeRbund_2.16.0    Gviz_1.18.2          rtracklayer_1.34.2   GenomicRanges_1.26.4 GenomeInfoDb_1.10.3  IRanges_2.8.2       
 [7] S4Vectors_0.12.2     fastcluster_1.1.22   reshape2_1.4.2       ggplot2_2.2.1        RSQLite_1.1-2        BiocGenerics_0.20.0 
[13] devtools_1.13.2      BiocInstaller_1.24.0


 

 

 

ADD COMMENTlink written 4 months ago by Oskar40

 

 

I'm having the same problem and when I use your fix I get the following error:

 require(devtools)
Loading required package: devtools
Warning message:
package ‘devtools’ was built under R version 3.3.2 
> install_version("RSQLite", version = "1.1-2", repos = "http://cran.us.r-project.org")
Downloading package from url: http://cran.us.r-project.org/src/contrib/Archive/RSQLite/RSQLite_1.1-2.tar.gz
Installation failed: Could not find build tools necessary to build RSQLite

I'm using a mac so it could be a compatibility issue, but any help would be greatly appreciated!

 

ADD REPLYlink written 4 months ago by jyoung0

You'll need to build RSQLite from source. For macOS, this requires XCode and compilers as described here.

ADD REPLYlink modified 4 months ago • written 4 months ago by Martin Morgan ♦♦ 20k

I am having the same problem for quite a few days now, with no solution. As others stated, the cummeRbund does load a previous cuffdiff data but not the new one. I get the same error message as @biakemi. After updating R to 3.4.1 and trying @Oskar recommendation, I still get the same result.

Here is my sessionInfo()

R version 3.4.1 (2017-06-30)
Platform: x86_64-pc-linux-gnu (64-bit)
Running under: Ubuntu 16.04.2 LTS

Matrix products: default
BLAS: /usr/lib/libblas/libblas.so.3.6.0
LAPACK: /usr/lib/lapack/liblapack.so.3.6.0

locale:
 [1] LC_CTYPE=es_UY.UTF-8       LC_NUMERIC=C               LC_TIME=es_UY.UTF-8        LC_COLLATE=es_UY.UTF-8     LC_MONETARY=es_UY.UTF-8   
 [6] LC_MESSAGES=es_UY.UTF-8    LC_PAPER=es_UY.UTF-8       LC_NAME=C                  LC_ADDRESS=C               LC_TELEPHONE=C            
[11] LC_MEASUREMENT=es_UY.UTF-8 LC_IDENTIFICATION=C       

attached base packages:
 [1] grid      stats4    parallel  stats     graphics  grDevices utils     datasets  methods   base     

other attached packages:
 [1] cummeRbund_2.18.0    Gviz_1.20.0          rtracklayer_1.36.3   GenomicRanges_1.28.3 GenomeInfoDb_1.12.2  IRanges_2.10.2       S4Vectors_0.14.3    
 [8] fastcluster_1.1.22   reshape2_1.4.2       ggplot2_2.2.1        RSQLite_2.0          BiocGenerics_0.22.0  devtools_1.13.2     

Anyone could solve this issue? Suggestions are welcomed!

ADD REPLYlink modified 4 months ago • written 4 months ago by splepre0

From your sessionInfo(), RSQLite is too new; you're aiming for the version in Oskar's post.

ADD REPLYlink written 4 months ago by Martin Morgan ♦♦ 20k

Yes, you are correct. Now, I followed Oskar's post strictly, and I can't load cummeRbund package. I get the following error:

> library(cummeRbund)
Loading required package: Gviz
Error: package or namespace load failed for ‘Gviz’ in loadNamespace(j <- i[[1L]], c(lib.loc, .libPaths()), versionCheck = vI[[j]]):
 namespace ‘RSQLite’ 1.1-2 is already loaded, but >= 2.0 is required
Error: package ‘Gviz’ could not be loaded
> sessionInfo()
R version 3.4.1 (2017-06-30)
Platform: x86_64-pc-linux-gnu (64-bit)
Running under: Ubuntu 16.04.2 LTS

Matrix products: default
BLAS: /usr/lib/libblas/libblas.so.3.6.0
LAPACK: /usr/lib/lapack/liblapack.so.3.6.0

locale:
 [1] LC_CTYPE=es_UY.UTF-8       LC_NUMERIC=C               LC_TIME=es_UY.UTF-8        LC_COLLATE=es_UY.UTF-8     LC_MONETARY=es_UY.UTF-8   
 [6] LC_MESSAGES=es_UY.UTF-8    LC_PAPER=es_UY.UTF-8       LC_NAME=C                  LC_ADDRESS=C               LC_TELEPHONE=C            
[11] LC_MEASUREMENT=es_UY.UTF-8 LC_IDENTIFICATION=C       

attached base packages:
 [1] grid      stats4    parallel  stats     graphics  grDevices utils     datasets  methods   base     

other attached packages:
 [1] BiocInstaller_1.26.0 RSQLite_2.0          devtools_1.13.2      rtracklayer_1.36.3   GenomicRanges_1.28.3 GenomeInfoDb_1.12.2  IRanges_2.10.2      
 [8] S4Vectors_0.14.3     fastcluster_1.1.22   reshape2_1.4.2       ggplot2_2.2.1        BiocGenerics_0.22.0
ADD REPLYlink written 4 months ago by splepre0

The basic problem is that cummeRbund needs to be updated for the recent RSQLite change.

The first solution is to wait for the maintainer to do this (they have been contacted). This requires patience.

The second solution is to basically 'make a mess' of your installation by downgrading packages to the version that works with the old version of RStudio. For GViz and other packages, you could use svn (http://bioconductor.org/developers/how-to/source-control/) or git / github(https://github.com/Bioconductor-mirror) to get the version before the maintainer updated their package. Generally, this will be tedious, require some skill / skill acquisition, and require patience.

ADD REPLYlink modified 4 months ago • written 4 months ago by Martin Morgan ♦♦ 20k

Had the same problem but the aforementioned solution worked for me. Just to reciprocate the assemblage: (i) Windows 10, (ii) R version 3.3.3, and (iii) RSQLite version 1.1-2. 

Thanks.

ADD REPLYlink modified 4 months ago • written 4 months ago by Shaurya Jauhari0

This does not seem to work always.  I kept getting error about `Gviz`, and `cummeRbund` not being compatible with `RSQLite` version `1.1-2`.  It worked on my Laptop, but cannot get it to work on the cluster.

ADD REPLYlink written 3 months ago by Sameet Mehta20
1
gravatar for gjkrenik
4 months ago by
gjkrenik10
gjkrenik10 wrote:

Also had this issue with the newest version of cummeRbund (installed on the newest version of R (3.4.1) with the newest version of Bioconductor).  Definitely seems to be a bug somewhere.

The most recent version of this package that I was able to get this function working was acquired by manually installing RSQLite_1.1-2 from source and then using the previous build of Bioconductor (3.4) to install cummeRbund.

Here's my sessionInfo() that allows for a working function:

attached base packages:
[1] grid      stats4    parallel  stats     graphics  grDevices utils     
[8] datasets  methods   base      

other attached packages:
[1] cummeRbund_2.16.0    Gviz_1.18.2          rtracklayer_1.34.2   
[4] GenomicRanges_1.26.4 GenomeInfoDb_1.10.3  IRanges_2.8.2        
[7] S4Vectors_0.12.2     fastcluster_1.1.22   reshape2_1.4.2       
[10] ggplot2_2.2.1        RSQLite_1.1-2        BiocGenerics_0.20.0 

 

ADD COMMENTlink written 4 months ago by gjkrenik10
1
gravatar for aaguero
4 months ago by
aaguero10
aaguero10 wrote:

1. Install R version: 3.3.2 from source

           from https://cloud.r-project.org/

           wget https://cloud.r-project.org/src/base/R-3/R-3.3.2.tar.gz

           tar xf R-3.3.2.tar.gz

            cd R-3.3.2

            ./configure

             make

2. Install bioconductor 3.4

          source("https://bioconductor.org/biocLite.R")

     biocLite()

3. Install RSQLite 1.1.2

     install.packages("https://launchpad.net/ubuntu/+archive/primary/+files/r-cran-rsqlite_1.1-2.orig.tar.gz")

 

ADD COMMENTlink written 4 months ago by aaguero10
1
gravatar for markus.ball
8 weeks ago by
markus.ball10
markus.ball10 wrote:

So no solution yet?

ADD COMMENTlink written 8 weeks ago by markus.ball10
0
gravatar for Oskar
4 months ago by
Oskar40
Oskar40 wrote:

Hi - I also have exactly the same issue. Not sure what is going on; but when I re-run an analysis (previously done with an old version) it turn out with the outcome posted by biakemi. Here is the output.

CuffSet instance with:

0 samples

0 genes

0 isoforms

0 TSS

0 CDS

0 promoters

0 splicing

0 relCDS

Any help will be appreciated.

ADD COMMENTlink modified 4 months ago • written 4 months ago by Oskar40
0
gravatar for ianmisner17
4 months ago by
ianmisner1720
United States
ianmisner1720 wrote:

I'm having the exact same issue. Using the newest versions of R and Bioconductor. Seems to be a bug in the latest release of cummeRbund.

ADD COMMENTlink written 4 months ago by ianmisner1720
0
gravatar for jkofsky
4 months ago by
jkofsky0
jkofsky0 wrote:

Very similar issue here. When trying to load cuffldiff output, my errors look like this:

Creating database /cuffData.db
Error in rsqlite_connect(dbname, loadable.extensions, flags, vfs) : 
Could not connect to database:
unable to open database file

or 

50+ of these:

1: In rsqlite_fetch(res@ptr, n = n) :
Don't need to call dbFetch() for statements, only for queries 

depending on how I submit it

The working directory is correct and I have formatted the input in as many ways as I can think of. I've re-run cuffdiff multiple times, still not working. Oddly, if I use cuffdiff output that was produced a year ago (using the same pipeline), it works.

I tried to get the package working by installing the other version on SQlite, but cummerbund will not proceed unless its updated. 


I'm stuck. does anyone have a suggestion?

jkofsky is offline Report Post  
 
ADD COMMENTlink modified 4 months ago • written 4 months ago by jkofsky0
0
gravatar for arpa530
4 months ago by
arpa5300
India
arpa5300 wrote:

Hi, I have been facing the same problem which I have mentioned below. 

cuff = readCufflinks(dbFile = "cuffData.db",
                       geneFPKM = "genes.fpkm_tracking",
                       geneDiff = "gene_exp.diff",
                       isoformFPKM = "isoforms.fpkm_tracking",
                       isoformDiff = "isoform_exp.diff",
                       TSSFPKM = "tss_groups.fpkm_tracking",
                       TSSDiff = "tss_group_exp.diff",
                       CDSFPKM = "cds.fpkm_tracking",
                       CDSExpDiff = "cds_exp.diff",
                       SplicingDiff = "splicing.diff",
                       CDSDiff = "CDS.diff",
                       PromotersDiff = "promoters.diff",
                       rebuild = T)

The output looks like:

Creating database C:/Users/Arpa.Samadder001/Desktop/new/cuffdiff/cuffData.db
Reading Run Info File C:/Users/Arpa.Samadder001/Desktop/new/cuffdiff/run.info
Writing runInfo Table
Reading Read Group Info  C:/Users/Arpa.Samadder001/Desktop/new/cuffdiff/read_groups.info
Writing replicates Table
Reading Var Model Info  C:/Users/Arpa.Samadder001/Desktop/new/cuffdiff/var_model.info
Writing varModel Table
Reading C:/Users/Arpa.Samadder001/Desktop/new/cuffdiff/genes.fpkm_tracking
Checking samples table...
Populating samples table...
Error: Column name mismatch.
In addition: There were 50 or more warnings (use warnings() to see the first 50)

 

I couldn't understand how to overcome this problem. Your help will be highly appreciated.

Thanks.

ADD COMMENTlink written 4 months ago by arpa5300
0
gravatar for karimhasanpur
3 months ago by
karimhasanpur0 wrote:

Dear all,

I followed all of the aforementioned recommendations but still face with the following error:

"Error: Column name mismatch.
In addition: There were 50 or more warnings (use warnings() to see the first 50)"

This error appeared when I updated my R and cummeRbund to the newest version. How can I solve this problem? Please help.
Kam

ADD COMMENTlink written 3 months ago by karimhasanpur0
0
gravatar for seungjoon.kim
3 months ago by
Berlin
seungjoon.kim0 wrote:

Hi I just installed cummeRbund and also have exactly the same issue with 50 or more warnings.

CuffSet instance with:

0 samples

0 genes

0 isoforms

0 TSS

0 CDS

0 promoters

0 splicing

0 relCDS

Seems not just my problems

 

ADD COMMENTlink written 3 months ago by seungjoon.kim0

I'm at the same point. I hope that this will get resolved through an update!

ADD REPLYlink written 11 weeks ago by brianagross0

Hello, 

I have the same error. Do you have any updates ?

ADD REPLYlink written 10 weeks ago by shastry.a0
0
gravatar for sdhutchins
10 weeks ago by
sdhutchins0
sdhutchins0 wrote:

I'm having the same issue. I've installed RSQLite version 1.1-2, but now it seems GViz won't load because of the cummeRbund version.

 

 

Loading required package: Gviz
Error: package or namespace load failed for ‘Gviz’ in loadNamespace(j <- i[[1L]], c(lib.loc, .libPaths()), versionCheck = vI[[j]]):
 namespace ‘RSQLite’ 1.1-2 is already loaded, but >= 2.0 is required
Error: package ‘Gviz’ could not be loaded
ADD COMMENTlink written 10 weeks ago by sdhutchins0

And after trying to download everything again, I get the following error:

Error in $<-.data.frame: replacement has 1 row, data has 0
ADD REPLYlink modified 10 weeks ago • written 10 weeks ago by sdhutchins0
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 2.2.0
Traffic: 317 users visited in the last hour