Search
Question: IRanges which are not S4 generic: endoapply mendoapply error in loading oligoclasses
0
gravatar for GENOMIC_region
4 months ago by
GENOMIC_region0 wrote:

I'm having issues for loading libraries:

Step1:

library("oligo",lib.loc="~/R_LIB")
library("pd.huex.1.0.st.v2",lib.loc="~/R_LIB")

Error:

Loading required package: IRanges

Error: package or namespace load failed for ‘IRanges’:
 Functions found when exporting methods from the namespace ‘IRanges’ which are not S4 generic: ‘endoapply’, ‘mendoapply’
Error: package ‘IRanges’ could not be loaded

Step2:

R CMD INSTALL IRanges_2.14.10.tar.gz -l ~/R_LIB
Error : package ‘BiocGenerics’ 0.24.0 was found, but >= 0.25.3 is required by ‘IRanges’
ERROR: lazy loading failed for package ‘IRanges’
* removing ‘../..path_path....../R_LIB/IRanges’

If I upgrade BiocGenerics I'm afraid I'll have to change/upgrade many other packages, too. Is there a workaround of this which can minimize installations? 

I tried to look for IRanges_2.13.X but in vain. I've Version: 2.12.0 Depends: R (>= 3.1.0), methods, utils, stats, BiocGenerics (>= 0.23.3),
        S4Vectors (>= 0.15.5)

Bioconductor version '3.6'

SessionInfo()
R version 3.4.2
other attached packages:
[1] S4Vectors_0.18.2    BiocGenerics_0.24.0
loaded via a namespace (and not attached):
[1] zlibbioc_1.24.0 compiler_3.4.2  affyio_1.48.0   Biobase_2.38.0 

Thanks.

ADD COMMENTlink modified 4 months ago • written 4 months ago by GENOMIC_region0
2
gravatar for James W. MacDonald
4 months ago by
United States
James W. MacDonald48k wrote:

You should never use install.packages directly, but instead should use biocLite. So you could do

library(BiocInstaller)
biocValid()

And then follow the instructions that are given. But do note that you are using an outdated version of R and Bioconductor, and we only offer support for the current versions. If you want help, install R-3.5.0 and then install all the packages you want using biocLite. Unfortunately there isn't a 'workaround of this that can minimize installations' because the whole idea for R and Bioconductor is that we are continually improving and adding things. If you want to stick with old versions, that's completely at your discretion, but we cannot support anything but the current release versions.

ADD COMMENTlink written 4 months ago by James W. MacDonald48k

Thank you for your reply. That helps; I'd to downgrade certain packages that were too new for Bioconductor version '3.6'. 

ADD REPLYlink written 4 months ago by GENOMIC_region0
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 2.2.0
Traffic: 230 users visited in the last hour