ensembldb package installation issue
0
0
Entering edit mode
@dylangagler-23915
Last seen 14 months ago

Hi all. I'm working through the tutorial for single-cell analysis (https://osca.bioconductor.org/quality-control.html) and when I run this block of code

`library(scRNAseq)
sce.416b <- LunSpikeInData(which="416b") 
sce.416b$block <- factor(sce.416b$block)`

I get the following error

`Error: failed to load resource
  name: AH73905
  title: Ensembl 97 EnsDb for Mus musculus
  reason: require(“ensembldb”) failed: use BiocManager::install() to install package?`

The package installation seems to go off without an issue using the following code

BiocManager::install("ensembldb")

but when I rerun the original code, it says that ensembldb is not installed.

Here is the output of my ensembldb installation code:

~~~~
Bioconductor version 3.11 (BiocManager 1.30.10), R 4.0.2 (2020-06-22)
Installing package(s) 'ensembldb'
trying URL 'https://bioconductor.org/packages/3.11/bioc/bin/macosx/contrib/4.0/ensembldb_2.12.1.tgz'
Content type 'application/x-gzip' length 3403123 bytes (3.2 MB)
==================================================
downloaded 3.2 MB

The downloaded binary packages are in
    /var/folders/t7/syy6zn4d29x1ywdlr12mjg8h0000gn/T//RtmpOMOFvy/downloaded_packages
~~~

I checked the libPath() and there is only 1 path here. Does anyone have any ideas about how to solve this issue?

ensembldb package installation BiocManager • 325 views
ADD COMMENT
0
Entering edit mode

Can you load the library with library(ensembldb)?

ADD REPLY

Login before adding your answer.

Traffic: 241 users visited in the last hour
Help About
FAQ
Access RSS
API
Stats

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.

Powered by the version 2.3.6