openCyto trouble importing xml file
2
0
Entering edit mode
Rivka • 0
@rivka-11959
Last seen 4.3 years ago
Munich

Hello,

I am very new to openCyto and trying to  import a xml file (being a workspace from FlowJo.) I keep getting an error saying 

"Error in xpathApply(x, "/Workspace", function(x) xmlGetAttr(x, "version"))[[1]] : Indexing beyond border

# Open workspace
wsfile<-"flowjo_ws.xml"
ws<-openWorkspace(wsfile)

Fehler in xpathApply(x, "/Workspace", function(x) xmlGetAttr(x, "version"))[[1]] : 
  Indizierung außerhalb der Grenzen

 

Thanks, Rivka

opencyto bioconductor R • 822 views
ADD COMMENT
1
Entering edit mode
Jiang, Mike ★ 1.3k
@jiang-mike-4886
Last seen 12 days ago
(Private Address)

Looks like the version information is missing in your xml file. Could you send it to wjiang2@fhcrc.org and I can take a look at it?

ADD COMMENT
0
Entering edit mode
Rivka • 0
@rivka-11959
Last seen 4.3 years ago
Munich

Hey,

it was a problem of the xml-file itself. I fixed it and now it's working.

ADD COMMENT
0
Entering edit mode

Hey,

Could you please explain what you changed in your xml file? I have the same problem to import workspace from flowjo.

Thanks a lot in advance!

Ekaterina

 

ADD REPLY
0
Entering edit mode

Hello,

sorry I did not see your comment earlier due to our new baby:-)

What I changed: I did not use the actual xml file but just the workspace,that you can download from flowjo, and has the suffix .wsp and that worked for me. See picture more more information:  https://goo.gl/photos/KcK9CDTAvfkTqhddA

Rivka

ADD REPLY

Login before adding your answer.

Traffic: 213 users visited in the last hour
Help About
FAQ
Access RSS
API
Stats

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.

Powered by the version 2.3.6