Question: BioC and genevisR and maftools
0
gravatar for Bogdan
2.8 years ago by
Bogdan580
Palo Alto, CA, USA
Bogdan580 wrote:

Dear all, I am aiming to install 2 recent BioC packages, ie. GeneVisR and maftools on my Linux ubuntu machine, that runs : Bioconductor 3.2 (BiocInstaller 1.20.3), R 3.3.2 (2016-10-31).

The message I am getting is : 

"package ‘maftools’ is not available (for R version 3.3.2"

or 

"package ‘GeneVisR’ is not available (for R version 3.3.2)" 

Please, could you advise on how to install these packages ? if I need BioC 3.4, how shall I update from BioC 3.2. to 3.4 ?

The error message I am getting is :

>  biocLite("BiocUpgrade")
Error: Bioconductor version 3.2 cannot be upgraded with R version 3.3.2

ADD COMMENTlink modified 2.8 years ago • written 2.8 years ago by Bogdan580
Answer: BioC and genevisR and maftools
2
gravatar for James W. MacDonald
2.8 years ago by
United States
James W. MacDonald51k wrote:

You have a complete mismatch between your Bioconductor and R versions. BioC 3.2 was intended for R-3.2.x

You should restart R, then do

source("https://www.bioconductor.org/biocLite.R")
biocLite()

Which should get you the correct version of BiocInstaller, which will then install the correct version of packages.

Also, do note that it's GenVisR, not GeneVisR.

ADD COMMENTlink written 2.8 years ago by James W. MacDonald51k
Answer: BioC and genevisR and maftools
0
gravatar for Bogdan
2.8 years ago by
Bogdan580
Palo Alto, CA, USA
Bogdan580 wrote:

Thank you James, will fix it ;) have a good weekend !

ADD COMMENTlink written 2.8 years ago by Bogdan580
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 16.09
Traffic: 414 users visited in the last hour